Jump to content

Forums

Auto-assigned Wrong Group


Daedious
 Share

Recommended Posts

Hello,

This is probably just user error, but I have looked everywhere to correct this setting. Currently I have new applicants who are approved auto assigned to Recruit usergroup, but it actually assigns them as members and then places them in recruit as a secondary group. How to I stop it from auto assigning them as members?

Link to comment
Share on other sites

  • Administrators

@Daedious, PERSCOM does not contain a setting that places a user in a user group after being approved. The only time PERSCOM assigns a user to a user group is when editing a personnel file (this is done in the processing stage of applications as well). When you save the personnel file and you've allowed PERSCOM to manage uaergroups, they will be placed in the combat user group they are assigned to and all the admin uaergroups they are assigned to. Perhaps one of the combat/admin units is linked to the wrong forum user group?

Also, PERSCOM does not manage primary uaergroups. Everything done is as a secondary user group.

Owner
Deschutes Design Group LLC
email | jon@deschutesdesigngroup.com

Link to comment
Share on other sites

Im a more confused now haha. So I removed the option place anyone in a group under PERSCOM > Applications > Settings > Usergroup Management. 

I then tried to change a members usergroup and received this error:
 

Error: Call to undefined method IPS\perscom\extensions\core\MemberFilter\Soldier::matches() (0)
#0 /home/fortheking/webapps/mainsite/forums/system/Member/Member.php(3934): IPS\Member\_GroupPromotion->matches(Object(IPS\Member))
#1 /home/fortheking/webapps/mainsite/forums/system/Member/Member.php(358): IPS\_Member->checkGroupPromotion()
#2 /home/fortheking/webapps/mainsite/forums/applications/core/extensions/core/MemberACPProfileBlocks/Groups.php(110): IPS\_Member->save()
#3 /home/fortheking/webapps/mainsite/forums/applications/core/modules/admin/members/members.php(1106): IPS\core\extensions\core\MemberACPProfileBlocks\_Groups->edit()
#4 /home/fortheking/webapps/mainsite/forums/system/Dispatcher/Controller.php(85): IPS\core\modules\admin\members\_members->editBlock()
#5 /home/fortheking/webapps/mainsite/forums/system/Dispatcher/Dispatcher.php(152): IPS\Dispatcher\_Controller->execute()
#6 /home/fortheking/webapps/mainsite/forums/admin/index.php(14): IPS\_Dispatcher->run()
#7 {main}


Its odd because it shouldn't affect that should it? I tried to change it back and I still receive the same error.

Link to comment
Share on other sites

Well. im not happy that it decided to resolve itself because I dont know what the issue was, but this is what I did.
 

  1. Updated my theme to latest version
  2. disabled perscom plugins and application
  3. changed a users group
  4. enabled perscom again

Seems to be working fine now....

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.